FOB Tutorial

Pro/DESKTOP 8

Assembly, Sweep, Helix
Prepared by Anthony Rossi

What you should familiar with
before starting this tutorial.

>
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Windows and PCs
Pro/Desktop GUI
Sketching Tools
Extrude
Dimensioning

What you will learn by completing
this tutorial.
> Assembly Constraints
o Mate
o Center Axis
o Align
> Sweep
> Along path
> Helical
> Adding color to components




This tutorial has been designed to introduce students to some of the
fundamentals of Pro/DESKTOP 8. The goal of this project is to design one
complex and two simple parts, and o complete an assembly. Good luck!

Conventions of this Tutorial

Since most people who attempt this tutorial will have had adequate exposure
to Pro/DESKTOP, there are minimal descriptions of operations and concepts.
When features are introduces, instructions will use keyboard shortcuts.
These will be shown as capital letters within brackets [**]. Feature
commands (extrude, revolve, etc.) will also be shown in brackets but with
the Control key or Alternate key followed by a plus sign (+) as a preface,
and multiple key strokes separated by a comma.

Example, to create an extrusion using keys rather than the icon, one would
first press down the Alt key, then while holding it, press and release the R
key once, then press and release the E key, and finally release the Alt Key.

In notation form, extrusion looks like this: [Alt + R, E].

Sequential operations will be indicated by commands separated by an arrow
[>]. For example, the following command "[C] > Drag a circle” means - type
the letter "C" key on your keyboard to select the circle sketching tool, and
then drag a circle.

Set Up

There are a few things you will need to do to get your computer ready for
this tutorial. This project has been done in INCHES. The first thing you will
need to do is make sure that the unit of measurement on your computer is
set to inches.

1. Open Pro/DESKTOP

» Start > Programs > PTC Pro/DESKTOP 8.

> From the file menu > go to Tools > Options.
» Select the Units tab > change the units to Inches in both fields > OK.



Component 1 - Main Body

Select workplane
> Right click the Frontal
workplane in the Workplane
Browser
> Select New Sketch
» Name this Body

Sketch for body

> [R] > Sketch rectangle =

> [Z] > Dimension as shown
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Extrude Profile
> [Alt + R, E]
> Add Material
> Above Work Plane
> Distance: 2"
> OK

Extrude Profile

Feature name:

iextrusion 1

Sketch to use az profile:
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2]l
Other Side | ok |
Cancel

* Add material
" Subtract material

" Intersect material

Extruzion -
Distance: [in): [~ Thin
o phove workplane : :|
~
Below workplane ¥ 5

" Symmetric about workplane

Taper angle: |0

Breview v
Lalculator

Round Edges
> [Alt + R, O]

> Constant Radius

» Radius = 0.125"

» Select the 4 Edges that run
the length of the body

> OK

Round Edges
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Feature name:
raund 1|

Round

oK

& Constant radius
" Wariable radius
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¥ Found tangent edges

Cancel

Preview W
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Round Top End
> [Alt + R, O]
Constant Radius
Radius = 0.0625"
Select all Edges of front
end of body
OK
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Round Edges

L . Found

Feature name;
round 2
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+ Constant radiuzs
" ariable radius

¥ Round tangent edges
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Cancel

Preview v
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Add a new Sketch to a face

> [F]> Select front face of
body

> Right click > New Sketch >
Name it loop

» [S]> Sketch a Straight Line
0.5" long, dimensioned as
shown.
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Extrude the loop

> [Alf + R, E]
Add material
Above Workplane
Distance: 0.4"
Check Thin
Thickness: 0.1"
OK
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Extrude Profile

FEeature name:

extrugion 2

Sketch to uze as profile:
laop -
& Add material
" Subtract material

" Intersect material

Estrusion -
Distance [in]:

.4

* Above workplane

" Below workplane

¥ Thin

X Thigkness [in):
01 -
¥ Syrarnetric

" Summetric about workplane

Taper angle: |0

Cancel

Preview ¥
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Round Edges on Loop
> [Alt + R, O]
» Constant Radius
> Radius = 0.25"
> Select vertical Edges of
Loop
> OK

Note: See image to right to
indicate which edges to select.

Add a new Sketch to a face
> [F1> Select face on top of
Loop
> Right click > New Sketch >
Name it hole

New Sketch

Fill patterr:

Ihn\e

I Rigid

| * Create warkplane

holg

base

Sketch this valid profile

> [C]> Sketch a 0.18"
diameter circle

> Dimension as shown

£ Add to workplane:

= Zlig _El

¥ Filled




Extrude Hole

> [AlT + R, E]
> Subtract Material
> Below Workplane
> Distance of 0.2"*
> OK

*Note: Distance of extrusion not
critical in this step, since the
extrusion will pass thru entire
solid.

Extrude Profile
Feature name:

Iextrusion 3

Sketch to use as profile:
hiale: >

© Add material
' Subtract material

7 Intersect material

Round Edges on Loop
> [Alt + R, O]
» Constant Radius
» Radius = 0.03"
> Select shown Edges of Loop
> OK

Round Edges

‘gz -

Feature name:
raund 4

— Extrusion
Distance [in):
I.2E‘ vI
 Above workplane
" Below workplane

" Symmetric about workplane

Taper angle: IU
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Beverse | ok
% Constant radius Cancel
€ Variable radius
¥ Round tangent edges Ereview
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Other Side. | oK
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Cancel
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Preview |
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Add a new Sketch to a face
> [F]> Select back face of
body
> Right click > New Sketch >
Name it path, as well as the
workplane

New Sketch

Mame: Color: Fill patterr:
|path |D j | j Cancel

[~ Bigid

* Create workplane

path|

™ Add to workplane:

¥ Filed

Project lines into new sketch
> With the face still
highlighted, [Alt + L, P] to
create the sketch

Create New Workplane

> [Shift + S] to view the
current workplane
[Alt + K, W] to create a
new workplane
Select Offset
Using the handle, left click
and drag the new workplane
to the center of the body
Name this Workplane
"profile”
OK

>

Workplane

*1 -

" Plane of object

& Dffset

" Angled

" Tangent

" Plane through objects
" Mid plane

Harme:

|pr0file
Offset (in):

n7ze -

Angle:

o

Eeference workplane:

R

Cancel

Preview W
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Add New Sketch to Workplane
> [W1]> Left click the newly
made workplane to select it
> Right click > New Sketch >
Name it profile
> OK

\
[ EE ]

Name: Caolar: Fill pattern:

profile Z i

| ||:I J | J Cancel
I Rigid v Filled

" Create workplane

& Add o workplane:

Sketch this valid profile
> [Shift + W] to view current
workplane
> [€C]> Sketch acircle
> [Z]> Dimension as shown

Sweep first 6rip

> [Alf + R, S, S]

> Select grip profile as
sketch to use as profile

> Select grip path as sketch
to use as path

> Subtract Material

> Name this feature “grip”

> OK

Sweep Profile

usoaspalie:  Sketchto use as pat
| pan

O Add material

* Sublract material

w{ﬁﬁ;ec}a/wal




Create Multiple Grips

> [A] > Select grip

> [Alt + R, A]

> Direction > Edges > Select

the shown edge

> Number of Instances: 6

» Spacing: 0.1"

> OK
*Note: if the preview shows the
additional grips in the wrong
direction, click the button labeled
"Reverse”

Round Bottom Edges on Body
> [Alt + R, O]
Constant Radius
Select rear Edges of Body
Radius = 0.125"

>
>
>
> OK

Pattern Feature

MName: Igrip pattem
Direction 1 | Parameters 1 I Directi0n2| F‘arameters2| Cancel
Direction—————————————————

ﬁ 1 v| Beverse |

™ lgnore member Failures

Murber of instances:
5 =

S

Spacing 5 [in]: —M—@—
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Preview v
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Round Edges

‘gs -

FEeature name:

 |round 4

Round

¥ Found tangent edges

Heverze | Ok I
Cancel |

& Constant radius
" Yariable radius

Freview v

Badius [in): I.h25 vl LCalculator |

Add a new Sketch to face
» [F]> Select face on top of
Body
> Right click > New Sketch >
Name it buttons
> OK
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Sketch construction lines

> [R] > Sketch a rectangle
close to the middle of the
solid

> [Z] Dimension as shown

> [L] Select all lines of
rectangle > [Ctrl + 6] to
make them construction
lines

Complete Sketch

> [€C]> Sketch a circle at each
corner of rectangle

> [Z] Dimension one circle to
be 0.3" in diameter

> [L] Select all circles > [Alt
+ C, Q] to make equal
radius

Extrude Buttons
> [Alf + R, E]

> Subtract Material

> Below Workplane

> Distance of 0.125"

> OK

[Alt+ + F, S] > Save this design as

“remote”
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Component 2 - Ring

Sketch this valid profile
> [Ctrl + N] Open a new
design file
> [C€]> Sketch a circle &
> [Z] > Dimension circle to K J
be 0.04" —
» Name this sketch “ring”

@, 04

Constrain Sketch -
> [S]> While holding shift, :

sketch a straight line from

the center of the circle to

the left, then from the ,

end of that line straight d _______________________________________________ e

up I ~
> [Z] Dimension the lines as L . \,J[”

shown

» [L] > select both lines > [6]
to make them construction
lines

E B F0.04
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Create Helix

>
>

A\
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[Alt + R, S, H]

Select ring as sketch to
use as profile

Select the vertical line to
use as the axis

Add Material

Pitch: 0.0425"

(0] ¢

[Alt + F, S]> Save this
design as “ring”

Helical Sweep |

.. Feature name;
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Sketch to use az praofile;
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Fitch [in]:

Cancel
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I

F

| ririg
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{* Right-handed
= Left-handed

& fdd material
i~ Sublract matenial

™ Reverze direction

Ags: Y91 -

Breview W
T aper angle: IU

Calculatar |




Component 3 - Button

Sketch this valid profile oz
» [Ctrl + N] Open a new

design file

> [€C]> Sketch acircle T_.

> [Z] > Dimension circle to
be 0.29"

> Name this sketch
“Button”

Extrude Buttons
> [Alt + R, E] 9
> Add Material .o
» Above Workplane '
> Distance of 0.3"
> OK

Round Edges on Loop and Body

> [Alt + R, O]
> Constant Radius
» Radius = 0.125"
> Select top Edge
> OK
> [Alt + F, S]> Save this
design as "button”
Round Edges ' N 2]
‘B_IJ o m
| |
¥ Found tangent edges M
Badusln [0125  v] | Caloulator |
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Assembly

Insert Remote and Ring

> [Ctrl + N] to open new design
[Al+ + A, A] > Select “remote.des”
OPEN > [Ctrl + F] to fix component
[Alt + A, A]> Select “ring"
Separate two components so that ring
is visible

YV V V VY

Constrain Assembly (Align)

» [F]> While holding shift, select both
flat face of ring and top surface of
loop

> [Alt + A, L] to Align faces

Move Component
» [P]> Select and drag ring into the
position shown
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Insert Component (Button)
> [Alt + A, A] > Select "button.des”
> OPEN
> Repeat until four buttons are on the
screen

Constrain Assembly (Align)

» [F]> while holding shift, select
cylindrical face of button and inside
cylindrical face of button hole

> [Alt + A, X] to Center Axis

Constrain Assembly (Mate)

» [F1> while holding shift, select both
bottom of one of the buttons and
bottom surface of one of the holes

> [Alf + A, M] to Mate

Constrain Assembly (Mate, Align)
> Repeat this process for each of the
buttons, so that the resulting assembly
matches shown model
> [Alf + F, S]> Save this design as
“FOB”

16



*NOTE ON ADDING COLOR TO COMPONENTS™

Color was added to the components in this section for aesthetics. It is not necessary
to add such detail. However, if a different color is desired, follow these steps to do
so. This process can be used at anytime during an assembly or design.

Select part

> Right click to view option menu
» Select Set Component Color

> [P]> Left click desired part to select it

View

ascale Selection

Material Properties...

Select Color

> Left click desired color

> Click Add to Custom Colors

> OK

*Note: Use of the bar on far right-hand side
can be used to further exact the color shade

m Synchronize Browser

Mass Properties...

Cugtarn colars:

EpEEEEEN -
Hue:fﬁl’a—" Hed:f‘l—E-E
I_r—r_.[_.]_r“]-—r- ‘ - Sat:{ﬁ Green:ﬁﬁ
| ColotSold |y [175  Bhue: 221
QK. | Cancel ] Add to Custom Colars ‘
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